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Question

This entry is from the Service&Support portal of Siemens AG, Sector
Industry, Industry Automation and Drive Technologies. The conditions of
use specified there apply (www.siemens.com/nutzungsbedingungen).

Go to the following link to download this document.

http://support.automation.siemens.com/WW/view/de/19701610

Question

How do you do an operating system update (OS update) on operator
panels with ProSave?

Answer

Follow the instructions and notes listed in this document for a detailed
answer to the above question.

OS_Update_ProSave
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Operating system update with ProSave

Below is a summary of how to do an operating system update with
ProSave.

The operating system of the operator panel depends on the version of
WiInCC flexible and ProTool used.

You should do an operating system update whenever the operating
system of the operator panel does not match the software version used.
Information on this is available in section 1.1.

If no operable operator panel image exists on the operator panel, you
can only update the operating system by means of a reset to factory
settings.

Information on this is available in section 1.2 and section 1.3.

If you have questions on establishing the connection or problems with
the operating system update, please refer to
chapter 2 and chapter 3 respectively.

Operating system update (OS update)

Please proceed as follows to perform an operating system update.

Table 1-1

No. Procedure

1.

Setting the PG/PC interface
In the SIMATIC Manager, you select the menu command Tools > Set

PG/PC Interface... and set interface parameter assignment used, for
example, CP 5512 (PROFIBUS).

Make transfer settings on the operator panel

Make the corresponding transfer settings on the operator panel and then
switch the operator panel to Transfer mode.

Establish cable connection

Connect the operator panel to the PG/PC with an appropriate connection
cable (according to the transfer setting selected).

ProSave
Start ProSave via "Start > SIMATIC > ProSave > ProSave".

In the ProSave menu bar you select the General menu and define the
device type and connection.

Switch to the "OS Update" menu in the menu bar.

Now, by default, an Image version appropriate for your operator panel is
displayed.

Note:
Make sure that the correct Image path is set.

This applies, in particular, if WinCC flexible and ProTool are installed
jointly on your computer (see also section 2.2).

Click on the "Device status" button.

OS_Update_ProSave
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1 Operating system update with ProSave

No. Procedure

A connection is established between "ProSave" and the "operator panel”.

8. After the connection has been established successfully, the current
image version of the operator panel is displayed.
Click on the "Update OS" button. The operating system update is
started.

9. Transfer the project
After the installation is complete, the "Control Panel" is displayed on the
operator panel.
For a subsequent project transfer, you first make the required transfer
settings.
For Touch operator panels, you should calibrate the screen beforehand
under
"Control Panel > OP > Touch".

10. Now you can transfer the configuration.

1.2 Resetting the operating system to the factory settings via the

"Reset to factory settings” function and PPI Multi Master cable

Proceed as follows to reset an operator panel to the factory settings.

Table 1-2

No.

Procedure

1.

Backup of licenses and authorizations

Before resetting your operator panel to the factory settings, make sure
that there are no licenses or authorizations on the operator panel.
Information on this is available in

Entry ID: 27005215

Make transfer settings on the operator panel
No transfer settings need to be made on the operator panel.

Switch off the power supply for the operator panel.

Establish cable connection

Connect the operator panel to the PG/PC using an appropriate
RS232/PPI multi-master cable or USB/PPI multi-master cable.
Settings on the USB/PPI multi-master cable

The USB/PPI multi-master cable ("E-Stand 05") does not have any DIP
switches and can be used for project transfer as from WinCC flexible
2005 SP1.

Settings on the RS232/PPI multi-master cable
For the operating system update you must set the fifth DIP switch to the
ZERO position (PPI/Freeport). All other DIP switches are not relevant for
operating system updates on an operator panel.

OS_Update_ProSave
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No.

Procedure

8 7 6 @ 4 3 2 1

The DIP switch settings are marked with 0 and 1 on the cable housing.

Note:

If you reset the operating system to the factory settings, you cannot use
all the communication connections and cables.

Information on which cable you can use for which operator panel is
available in section 2.1.2.

ProSave
Start ProSave via "Start > SIMATIC > ProSave > ProSave".

In the ProSave menu bar you select the General menu and define the
device type and connection.

For a PPI connection you select "Serial" as the connection type. You do
not have to set the baud rate on the multi-master cable for an operating
system update.

Switch to the "OS Update" menu in the menu bar.

Now, by default, an Image version appropriate for your operator panel is
displayed.

Note:

Make sure that the correct Image path is set.

This applies in particular if WinCC flexible and ProTool are installed
jointly on your computer (see also section 2.2).

Check the "Reset to factory settings" check box or the "Boot" check
box (in earlier versions of ProSave).

Note:

If the "Reset to factory settings" check box is not displayed, refer to
section 3.2.

Click on the "Update OS" button and switch the operator panel back on.

A connection is established between "ProSave" and the operator panel
and the operating system update is started.

After transfer of the data, "ProSave" requests you to reboot the operator
panel (switch off and on).

The operator panel then performs additional installation steps.

10.

Transfer the project

OS_Update_ProSave
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1 Operating system update with ProSave

No. Procedure

After the installation is complete, the "Control Panel" is displayed on the
operator panel.

For a subsequent project transfer, you first make the required transfer
settings.

For Touch operator panels, you should calibrate the screen beforehand
under

"Control Panel > OP > Touch".

11. Now you can transfer the configuration.

1.3 Resetting the operating system to the factory settings via
Ethernet connection

Below we take the example of an MP 377 Touch to show how to reset an
operator panel to the factory settings via Ethernet.

Note MP 377 operator panels with the Image version installed for
WinCC flexible 2008 and higher (Image version as from
V01.00.02.00_01.83) have the new parameter "Prepare for Reset".

More information on this is available in
Entry ID: 35677293

Table 1-3

No. Procedure

1. Backup of licenses and authorizations

Before resetting your operator panel to the factory settings, make sure
that there are no licenses or authorizations on the operator panel.

Information on this is available in
Entry ID: 27005215

OS_Update_ProSave
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No.

Procedure

Assign IP address

Assign a unique IP address to your PG/PC and your operator panel.
Make sure that the IP addresses are in the same subnetwork.
Sample PG/PC

IP: 192.168.0.200

Subnetwork: 255.255.255.0

Sample operator panel

IP: 192.168.0.210

Subnetwork: 255.255.255.0

More information on how to establish an Ethernet connection between a
PG/PC and an operator panel is available in

Entry ID: 23800567

Set the PG/PC interface

In the SIMATIC Manager you select the menu command "Tools > Set
PG/PC Interface...".

Set the interface parameters used to

"TCP/IP -> Your network card".

PG/PC-Schnittstelle einstellen : |

Zugriffsweg |

Zugangzspunkt der Applik ation:
uS?DNLINE [STER 7] -» TCRAP -» dl
[Standard fiir STER 7]

Benutzte Schnittstellenparametrierung:

ITCF';"IP -3 Eigenzchaften. .. |
ahl=(PPI) | Diagnose... |
el

Kopieren..

@3 TCPAP -> 1394 Net Adapter
Bt Sevkmltieme S| e |
»

[Parametrierung [hrer MDIS-CPs mit TCRAP
Pratokall (RFC-1006]]

" Schnittstellen

Hinzufiigen/Entfernen: Auswahlen... |

Abbrechen | Hile |

Make transfer settings on the operator panel
No transfer settings need to be made on the operator panel.

Keep a record of the operator panel's MAC address.
Refer to section 2.3 for how to determine the MAC address.

Switch off the power supply for the operator panel.

OS_Update_ProSave
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No.

Procedure

Establish cable connection
Connect the operator panel and the PG/PC using an Ethernet cable
(cross-over or patch cable).

ProSave
Start ProSave via "Start > SIMATIC > ProSave > ProSave".

Communication 4
Office Applications 3

R tities

rﬂ Sirnakic TD Kevpad Designer ¥1.0.6,.35 #

Dacurentation 4

Accessories 4
Information 3

Lifebook Application Panel 4
Startup 4
:& Windows Messenger

b Windows Movie Maker

Windows Powershell 1.0 3

License Management

WinCC Aesible 2008
STEP7 v
WinCC fexible Runtine 2008 ¥

(%) Windaws Media Player

Switch to the "General" menu in the ProSave menu bar.

Select the appropriate device type and define "Ethernet" as connection.
For "Connection parameters" you enter the IP address of the operator
panel.

=« SIMATIC ProSave V7.4.2.0

Datel Sprache Hilfe

Allgemnein l Eackup] Hestore] Dptionen] 0s Update]

Geratetyp

[MP 377 12" Touch |
Werbindung

|Ethemet ﬂ

‘“Yerbindungzparameter

~ |P-Adiesse " Computernanme

192 164. 0 . &

Fertig MP 377 12" Touch  Ethernet

OS_Update_ProSave
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No.

Procedure

10.

Switch to the "OS Update" menu in the menu bar.

Now, by default, an Image version appropriate for your operator panel is
displayed.

Note:
Make sure that the correct Image path is set.

This applies, in particular, if WinCC flexible and ProTool are installed
jointly on your computer (see also section 2.2).

11.

Check the "Reset to factory settings" check box or "Boot" check box (in
earlier versions of ProSave).

The "MAC address" option field is then displayed.
Enter the operator panel's "MAC address" here.

Note:

If the "Reset to factory settings" check box is not displayed, refer to
section 3.2.

* SIMATIC ProSave V7.4.2.0 =3

Datei Sprache Hilfe

Allgemein ] Backup ] Restare ] Optionen D l

Imagepfad:

|2DDB\Images_WinCC_ermbIe_ZUDB\MPS??\MF‘3?7_V1_D_2_D.\mg Gerdtestatus

v aufwerkseinstellungen zuricksetzen
Oifnen von: C:\Program FileshSiemenshSIMATIC WinCC flexible\WinCC flexible 20084 mages_
Image fiir: MP 377 12" Ky, MP 377 12" Touch, MP 377 15" Touch, MP 377 15" Touch
‘windows CE: 5.0
Image Yersion: B1.020
Ok
% %

we [ [ [& -3 [2 o T

Fertig MP 377 12" Touch  Ethernet

Click on the "Update OS" button and switch the operator panel back on.
A connection is established between "ProSave" and the "operator panel".

OS_Update_ProSave
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No. Procedure

12. You will then receive a security warning.
Acknowledge it with "Yes" if you have no licenses installed on the panel.

Achtung! Wenn Sie dieze Funktion ausfihren, dann
gehen alle Daten und die auf dem Gerat inztallierten
Lizenzen urwideruflich verloren |

If you acknowledge with "Yes", the process continues.
The memory is deleted and the selected data is transferred.

13. Transfer the project

After the installation is complete, the "Control Panel" is displayed on the
operator panel.

For a subsequent project transfer, you first make the required transfer
settings.

In the case of Touch operator panels, you should calibrate the screen
beforehand under

"Control Panel > OP > Touch".

14. Now you can transfer the configuration.

OS_Update_ProSave
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Additional Information

Cable connection between PC and operator panel

Operating system update

When performing an operating system update, you can use all the

communication connections supported by your operator panel.

Resetting the operating system to the factory settings (booting)

If you reset the operating system to the factory settings, you cannot use all
the communication connections and cables.

Information on which cable you can use for which operator panel is
available in the table below.

Table 2-1
Operator RS 232 RS232/PPI USB/PPI PN PtP PN
Panel Zero modem | Multi-master | Multi-master Cross Ethernet
cable cable cable
6ES7 901- 6ES7 901- 6ES7 901- 6XV1 870- Standard
1BF00-0XAO0 3CB30-0XA0 3DB30-0XA0 3RH20" Ethernet
CATS5

OP 73 micro -- X X -- -
TP 170 micro -- X -- -- -
TP 177 micro -- X X -- -
C7-635
OP/TP X - - - -
C7-636 X 3 B N B
Key / Touch
OP 73 - X X - .
OP 77A - X X - .
OP 77B X - - - .
TP 170A X - - - -
TP 177A - X X - -
OP 170B X - - - -
OP 177B - X - - -
TP 170B X - - - -
TP 177B - X - - -
OP 270 X - - - .
OP 277 - X - - .
TP 270 X - - - .
TP 277 - X . - .
MP 270 X - - - -
MP 277 - X - - .
MP 370 X - - - -
MP 377 - - - X X
Mobile Panel X _ _ _ _
170

OS_Update_ProSave
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2 Additional Information

Operator RS 232 RS232/PPI USB/PPI PN PtP PN
Panel Zero modem | Multi-master | Multi-master Cross Ethernet
cable cable cable
6ES7 901- 6ES7 901- 6ES7 901- 6XV1 870- Standard
1BF00-0XA0 | 3CB30-0XA0 | 3DB30-0XA0 | 3RH20” Ethernet
CAT5
Mobile Panel _ X _ _ _
177
Mobile Panel _ X _ _ _
277
KTP400 Basic
mono ON - - - X X
KTP600 Basic
color DP - X X - -
KTP600 Basic
color PN - - - X X
KTP600 Basic
mono PN - - - X X
KTP1000
Basic DP - X X - -
KTP1000
Basic PN - - - X X
TP1500 Basic
PN - - - X X

) For the RS232/PPI multi-master cable, you set DIP switches 1 to 3
according to the baud rate selected in ProSave.
DIP switches 4 to 8 must all be set to ZERO.

OS_Update_ProSave
V2.1, Entry ID: 19701610
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Note

Set the image path / file in ProSave

In the following cases, you must change the image path or the image file
accordingly:

1. After you have set the ProTool image path for the operator panel
displayed, you must set the image path for WinCC flexible if you now
wish to use the same operator panel in WinCC flexible.

2. If you need an earlier version of Image than the one currently displayed.

e The image path setting is device-related. The setting is retained for the
selected panel type after ProSave is closed.

o Beforehand, make sure that the correct Image path is set. This applies in
particular if WinCC flexible and ProTool are installed jointly on your
computer.

In order to set the image path in ProSave, click the button to the right of the
image path and browse through the folder tree to specify the folder path in
which the image files are located.

In the folders you find the image files required for the respective operator
panel.

Figure 2-1
Image path:
|C “Program Files\SiemenshSIMATIC WinCC flexibleMwinCC flexible | @ Device status
Opening: C:\Program Files\Siemens\SIMATIC WinCC AexibleinCL flexible ImagesiM obil:
Image for: tobile Panel 277, MP 277 8" Key, MP 277 8" Touch, MP 277 10" Key, MP 2771
Pwiindows CE: 50
Image version B1.1.00
0k
Loak in | (£ WinCC flesible Images j £F ER-
A |2 Documents [ TPL704_Micro
S [IKTP178MICRO [LDTP1774A
My Recent |73 Mobile_MP277 CDTPL7 Micra
Documents |5 ybie op_TP170B
< 0 % (2 Mabile_CP_TP177E
- ([ MRa70
Deskiop CIMPETT
C)0P7a
//' (L) OP73micro
C)0P77a
Complsted My Documents op77E

() OP_TP270_MPZ70R

iﬁ_g L)0P_TRZ7T

-
1
My Computer

"’] File marne: | ﬂ Open |

- 5

My Network  Files of type |Image Dateien [*.img) j Cancel
Flaces

[ Open as read-only

OS_Update_ProSave
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Sample image path in WIinCC flexible 2 Additional Information

Sample image path in WinCC flexible
C:\Program Files\Siemens\SIMATIC WinCC flexible\WinCC flexible
Images\Operator panel...
Note The Image version of the operator panels depends on the version of
WinCC flexible and ProTool used.
More information on this is available at the following links.

ProTool:
http://support.automation.siemens.com/\WW/view/de/21742389

WinCC flexible:
http://support.automation.siemens.com/\WW/view/de/28263711

2.3 Determining the MAC address

Operator panels that use "Ethernet" as a connection for executing the
"Reset to factory settings” function need to have the MAC address
specified in order to execute the function.

You can determine the operator panel's MAC address as follows.

e The MAC address is printed on the back of the operator panel (e.g.
MAC-ADD.: 00-0E-8C-84-1F-87).

e When you switch on the operator panel, the MAC address is displayed
during startup.

¢ Via the "Control Panel" of the operator panel.
TP/OP/MP/Mobile Panel: Control Panel > OP > Device
KTP/TP1500 Basic Panels: Control Panel > Profinet > Device

OS_Update_ProSave
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Problem Analysis

Disconnected connection when using the RS232/PPI multi-
master cable

If the connection is disconnected when updating the operating system, set
a lower bit rate.

If you are using high bit rates, then you must implement the RS232/PPI
multi-master cable with "E-Stand 03" (development status 03) or higher.

Check box not available in ProSave

If the "Reset to factory settings” check box is not displayed, then recheck
the connection settings made in ProSave. It is possible that the operator
panel does not support the transfer type required for this option.

Refer here to Table 2-1 in section 2.1.2.

Error message during transfer of the configuration

You have changed the operating system of your operator panel and during
transfer of the configuration you receive the message that the operating
system version of the operator panel does not match the software version
used.

In this case, prior to updating the operating system, check that the image
path has been set correctly and that you have selected the correct image
file. Refer here to

section 2.2.

Example of an error message in WinCC flexible 2008.

Figure 3-1

Download is not possible. The "version of the device” in your WInCC flexible project and the version of the operating system of the device
@ are not compatible. Please perform an operating system update for the HVI device with the command "Project -> Transfer -> 0S
Update" ("Reset to factory settings” if necessary").

MP 377 "Reset to factory settings" (booting)

If the MP 377 operator panel cannot be reset to the factory settings, then
check the Image version of the MP 377.

MP 377 operator panels with Image version as from

WinCC flexible 2008 (Image version as from V01.00.02.00_01.83) installed
have the new parameter "Prepare for Reset".

In this case refer to Entry ID: 35677293.

OS_Update_ProSave
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Some points are given below, which you should check if no connection is established

3.5 A connection to the operator panel cannot be established

Some points are given below, which you should check if no connection is
established between the operator panel and ProSave.

351 Check transfer type and address on the operator panel and in
ProSave
Compare the transfer settings on the operator panel with those in ProSave.

Example:
ProSave specification

Transfer via PROFIBUS;
Panel address 10

Make sure that "Panel is the only master on the bus" is checked for the
transfer settings on the operator panel.

Figure 3-2

- Skation Parameters
| Panel is the only masker on the bus |

Address: I1d

Time-out: |1 5 EI
FMetwork Pararneters

Transmission Rate: |1J5 Mbits's EI

Highest Station Address: |126 EI

Prafile LP EI

Bus Parameters, .. I

More information on the topic of "transfer settings" is available at the
following link.
http://support.automation.siemens.com/WW/view/de/23802404

OS_Update_ProSave
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Check cable connection and connector

MPI/PROFIBUS cable
Please check the following points:

e Cable connection between the operator panel and the configuration
computer.

- Check the cable for damage.
e Bus connector especially the connection of the terminating resistors.
- Terminating resistors ON/OFF.
The following guideline value applies:
e Bus terminating resistor OFF:
- Bus connector with "two" cables connected.
e Bus terminating resistor ON:
- Bus connector with "one" cable connected.

More information on the topic of "bus terminating resistors" is available at
the following link.
http://support.automation.siemens.com/WW/view/de/187276

RS232/PPI multi-master cable

When using an RS232/PPI multi-master cable, please note the switch
settings.

Refer here to the entry at the following link:
http://support.automation.siemens.com/WW/view/de/16532946

Ethernet cable

Use a "crossed" Ethernet cable for the connection between a PG/PC and
an operator panel.
If you use a "patch" cable, you need a switch in addition.

OS_Update_ProSave
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Check the PG/PC interface on your configuration computer. 3 Problem Analysis

3.6.1

Check the PG/PC interface on the configuration computer

Check the PG/PC interface on your configuration computer.

e |n Windows XP

"Start > SIMATIC > SIMATIC NET > Set PG/PC interface".

e INSTEP7

"Menu bar: Tools > Set PG/PC interface..."

Make sure that the node address is set to "0".

We also recommend that you check the "PG/PC is the only master on the

bus" option.

Figure 3-3
Properties - CP5512{PROFIBUS)

FROFIEUS |

X]

Station Parameters
[+ PG/PC iz the only master on the bus

Address: 1] =

TimneoLt; 1z -

Metwark, Pararmeters

Transmizsion rake; 1.5 Mbps - |

Highest station address: 126 -

Prifile:

Jzer-Defined

riverzal [DPAFRS)

Buz Parameters... |

Metwork, Configuration

[ Usze the following nebwark, configuration

OS_Update_ProSave
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History
Table 4-1
Version Date Amendments
V1.0 20.09.2008 First edition
V1.1 07.01.2009 Addition inserted
V1.2 09.07.2009 Additions to MP 377 and KTPs inserted.
Tables changed.
V1.3 26.08.2010 Section 1.2 updated
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